Unable to connect to database.

scottt732's Avatar

scottt732

17 Jul, 2013 03:35 AM

When I try to launch ElectricMobileStudio2012.exe, I get 2 dialog boxes.

1st reads "Unable to connect to database."

When I dismiss that, a second one pops up that says "Unhandled exception: No connection associated with this command"

I'm a paying customer

  1. Support Staff 1 Posted by Shaun Sullivan on 17 Jul, 2013 12:58 PM

    Shaun Sullivan's Avatar

    Have you ever been able to run the product successfully?

     

    We use a local SQLite database to store settings, preferences etc. Worst case I think re-installing would fix it (if the file were lost or damaged somehow). You will not need to re-activate when re-installing, so please try that.

  2. 2 Posted by scottt732 on 17 Jul, 2013 02:12 PM

    scottt732's Avatar

    It's been a little while, but I was able to run the app successfully. I tried a re-install, tried renaming the .s3db file to .bak (I assume that's the sqlite db), undid that, tried granting Everyone Full Controll to the .s3db file. Still no luck. Any more aggressive steps I can try?

  3. 3 Posted by scottt732 on 18 Feb, 2014 05:43 PM

    scottt732's Avatar

    I'm still unable to start the app. Is there anyway you can help me troubleshoot this? If not, please refund my money. The product is useless to me. I start the app, I get the 2 messages shown above, and the app crashes. Incredibly frustrating. Feel free to contact me by e-mail.

  4. 4 Posted by Benny70 on 19 Feb, 2014 06:37 PM

    Benny70's Avatar

    I have the same Problem !!

    I can start the Program, it Comes always a Error
    "Unable to connect to database."

    Please give me a Feedback via Email to fix this Problem

  5. 5 Posted by scottt732 on 19 Feb, 2014 07:12 PM

    scottt732's Avatar

    The version just released today (ems_v114_setup.zip) seems to have resolved the issue for me.

  6. Support Staff 6 Posted by Shaun Sullivan on 19 Feb, 2014 07:24 PM

    Shaun Sullivan's Avatar

    Make sure your file system permissions are not messed up in the directory
    where the database is
    (c:\Users\[YOUUR_USER_NAME]\AppData\Local\com.electricplum.ems)

    That is typically a safe place to write. If that doesn't work. Uninstall
    the product, then delete the directory mentioned above and re-install.

  7. 7 Posted by Benny70 on 19 Feb, 2014 07:27 PM

    Benny70's Avatar

    Nö this new Version 114 Works Not by me!

    I have Windows 8.1

  8. 8 Posted by Benny70 on 19 Feb, 2014 07:43 PM

    Benny70's Avatar

    Ok i have Show in this Directory but if is empty !! no Database inside
    I give full Right for User Everyone and not helps

    I have uninstall and delete the Directory and new Install but not work,
    i become always the same Error

  9. 9 Posted by Andreasg on 19 Feb, 2014 07:48 PM

    Andreasg's Avatar

    i have the same problems like Benny70 and i'm using Windows 8.1 64bit

  10. Support Staff 10 Posted by Shaun Sullivan on 19 Feb, 2014 11:41 PM

    Shaun Sullivan's Avatar

    Hi can you try re-downloading and installing? Thanks.

  11. 11 Posted by Benny70 on 20 Feb, 2014 06:10 AM

    Benny70's Avatar

    Hello,

    Ok with the new Download ems_v114b_setup.zip it works now...

    but i become now another Error cannot write to C:\ProgramFiles(x86/ElectricPlum....

    I must set the Security Settings manualy to write in this Directory
    then works..

    Thanks

  12. 12 Posted by Andreasg on 20 Feb, 2014 06:15 AM

    Andreasg's Avatar

    now i have another error message (see attached screenshot, that meens "no access to quick_screenshots").. i have deleted the old version and reinstalled the new 114b-Version

  13. 13 Posted by Benny70 on 20 Feb, 2014 06:19 AM

    Benny70's Avatar

    Hallo Andreas,

    Ich habe das selbe Problem gehabt und ich habe die Sicherheit
    für dieses Verzeichnis per Hand eingestellt, also Schreibzugriff erteilt
    dann funktioniert es...

    Lg
    Benny

  14. 14 Posted by Andreasg on 20 Feb, 2014 07:11 AM

    Andreasg's Avatar

    Hallo Benny,
    welches Verzeichnis meinst du denn genau? das in users.../appdata oder Programme?

  15. 15 Posted by Benny70 on 20 Feb, 2014 07:19 AM

    Benny70's Avatar

    Hallo Andreas,

    Ich habe diesem Verzeichnis für den User "Jeder" Schreibzugriff erteilt, dann geht es..

    C:\Program Files (x86)\Electric Plum

    Gruß
    Benny

  16. 16 Posted by scottt732 on 20 Feb, 2014 04:51 PM

    scottt732's Avatar

    A few tips from a fellow .NET developer... Your application should not try to write files to %ProgramFiles% once it's installed. You should probably store the database file in a directory under %LocalAppData% or %AppData% (Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData) ... or .ApplicationData). Your installer should create this directory on install & prompt the user whether they want to remove it on uninstall. For upgrades, you'd want to leave it alone (unless your database isn't compatible in a future version).

    Your screenshots should default to save in or below the standard Windows pictures folder (Environment.SpecialFolder.MyPictures).

    I think this would address a lot of the NTFS permissions issues. If you want something a little simpler, but not in line with the best practices, grant the Users group the Modify privilege on the Electric Mobile Studio 2012 folder as part of the installation. You could use icacls for this if the installer software doesn't have something built in (http://technet.microsoft.com/en-us/library/cc753525.aspx).

  17. Support Staff 17 Posted by Shaun Sullivan on 20 Feb, 2014 05:51 PM

    Shaun Sullivan's Avatar

    Thanks!

     

     

     

    Shaun Sullivan

    Founder & CEO

    electric plum

     

     <tel:843-345-1231> 843-345-1231

    www.electricplum.com

  18. Support Staff 18 Posted by Shaun Sullivan on 20 Feb, 2014 05:58 PM

    Shaun Sullivan's Avatar

    BTW, we do store the database in c:\Users\[USER_NAME]\AppData\Local\com.electricplum.ems , but the default screen shot directory defaults to the local install directory. Thanks for the feedback, there are many things we can improve and I appreciate you taking the time to send such a thoughtful response.

     

    Best,

    Shaun

     

     

     

    Shaun Sullivan

    Founder & CEO

    electric plum

     

     <tel:843-345-1231> 843-345-1231

    www.electricplum.com

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

16 Oct, 2021 02:38 PM
06 Oct, 2021 05:12 AM
20 Sep, 2021 04:14 PM
02 Aug, 2021 04:22 AM
29 Jul, 2021 07:22 AM